Email Outage Impacting Service Desk

Incident Report for CTSI Global

Resolved

Microsoft has confirmed Exchange Online service has returned to expected levels and the impact has been remediated.

Still having issues? Submit a request: 👉 https://ctsiglobal.atlassian.net/servicedesk/customer/portals

REF: EX1221742
Posted Jan 23, 2026 - 20:20 CST

Investigating

We are tracking a Microsoft service alert that may cause intermittent difficulty accessing Exchange Online (Outlook) for users in the US, UK, Canada, and France.

What is happening?
Microsoft has identified a "code regression" (a bug in a recent update) affecting some of their mailbox servers. This is not a total outage, but it can cause:

Occasional connection drops or slow loading in Outlook (Web, Mobile, and Mac).

"Temporary server error" messages when sending or receiving specific emails.

Impact on Our Service Desk
Because this issue is intermittent, some emails sent to our Service Desk are currently being delayed.

If you need immediate assistance or do not receive an automated confirmation of your email, please log your request directly through our portal:

👉 Access the Service Desk Portal Here: https://ctsiglobal.atlassian.net/servicedesk/customer/portals

We will continue to monitor Microsoft’s progress on the fix and will provide an update once the service has fully stabilized.
Posted Jan 23, 2026 - 17:48 CST
This incident affected: Service Desk.