Service Desk Email Processing Delays

Incident Report for CTSI Global

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 28, 2026 - 14:00 CST

Investigating

There currently issues with the processing of email associated with Service Desk. You can still access the service desk directly, but email processing will be delayed.
Posted Jan 28, 2026 - 11:58 CST
This incident affects: Service Desk.