Email Outage Impacting Service Desk

Incident Report for CTSI Global

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 07:23 CST

Investigating

Due to the issue with Microsoft being unable to receive external emails, we are not able to receive emails sent to service desk. We are monitoring this situation. IN the meantime you can still login to service desk directly here: https://ctsiglobal.atlassian.net/servicedesk/customer/portals
Posted Jan 22, 2026 - 15:50 CST
This incident affected: Service Desk.