Service Desk Potential Impact from AWS Service Interruptions

Incident Report for CTSI Global

Resolved

AWS has resolved the issue on their end; all affected components are now operational and working as expected.
Posted Oct 21, 2025 - 08:16 CDT

Monitoring

AWS is experiencing service interruptions that have impacted our service providers.
They are currently investigating this issue and are providing frequent updates.
We are also monitoring the impact on our side as well and resolving any potential issues as quickly as possible.
Posted Oct 20, 2025 - 10:22 CDT

Investigating

AWS is experiencing service interruptions that have impacted our service providers. They are currently investigating this issue and are providing frequent updates.
Posted Oct 20, 2025 - 09:41 CDT
This incident affected: Service Desk.